
Cinelerra-GG Quick Start Guide

Cinelerra is a software program NLE, Non-Linear Editor, that provides a way to edit, record, and play 
audio or video media on Linux.   It can also be used to retouch photos, watch TV, and create DVDs.

1 –   Install   the software   
2 - Start Cinelerra program  
3 - Load media  
4 – Choose Output Format  
5 - View and Listen  
6 - Edit/Compose  
7 - Backup you  r   work      
8 - Create your new media  
9 - Play your new media  

1 - Install the Software
On the internet, click on the Download page at:  https://cinelerra-gg.org/downloads/
Here you will see several Operating System distro packages that are already built for you to download.  
Click on your preference and read the specific instructions for usage.

. . . 

However, if you want to get going as quickly as possible, just do this so that everything is in 1 place:

   Download your Operating System’s tar file from https://cinelerra-gg.org/download/tars/ to /tmp .
   Keyin:  cd /name-of-directory-where-you-want-the-software (for example, cd /software)
   Keyin:  mkdir cin
   Keyin:  cd cin
   Keyin:  tar -xJf /tmp/cinelerra-5.1-*.txz   (if you put the tar in /tmp AND replace * with full name)

https://cinelerra-gg.org/download/tars/
https://cinelerra-gg.org/downloads/


2 - Start Cinelerra program

Depending on how you installed the software, you can log in as root or as a user if you used a package.

        Keyin:  /your-software-directory-path/bin/cin 
        Or if you installed using the pkg method, click on the Cin icon.

You will now see 4 separate windows appear.  The top 2 windows from left to right are the Viewer 
which is most useful for previewing clips and media and the Compositor which displays the current 
working frame at the timeline position.  The bottom 2 windows are the Cinelerra Program, also called 
the timeline, which is where the real work gets done and the Resources window showing a selection of 
media or effects.

Any of these windows can be resized to better suit your needs.  Note that if your system’s native 
language is not English, some of the words you see on the screen will be correctly translated for you, 
others will be in english, and some will have not very good translations.

It is important to know that Cinelerra does not directly change your media.  It writes all changes to 
what is called the EDL, Edit Decision List.  This way you original media remains completely intact.

Figure 1:         Viewer Window                                                      Compositor Window

Figure 2:         Main / Program / Timeline                                         Resources Window



3 - Load Media
On the main timeline program window are many pulldowns, the first of which is “File”.  

1) Click on File for a list of available options and note that in the right hand column are shortcuts for
     many of the options that will come in handy if you use Cin often.  
2) Next click on the second one down - “Load files” - which brings up the Load menu.
  

  

  3) Below “Select files to load” on the top left side is a textbox and if you look all the way to the right
      side of the textbox, there is a down arrow which you use to navigate your file system.  Highlight the
      desired file system and you will see that directory name appear in the textbox and the files below.
 4) Scroll to the media file you would like to work on and highlight that file.  When you do, you will
      see that filename also appear in the textbox below the listing of files.  You could have directly
      keyed in that file in that textbox instead.
 5) On the bottom of the Load menu, is a box called “Insertion strategy”.  For getting started the
      default of “Replace current project” is sufficient.  But you can click on the down arrow to see what
      is available for future use.
 6) Now click on the green-colored checkmark on the bottom left-hand side to actually load the file
      and see it appear on the timeline in Cinelerra’s main window and a single frame in the compositor.
     The first track will most likely be video thumbnails and the next tracks may be audio waveforms.
 7) Press the space bar in the main Program window and your video will start playing and press the
      space bar again to stop the play.  While playing, you should see the video in the Compositor
      window in the upper right hand side of your screen and if you have your audio hooked up, you
      will hear the sound.  To get back to the beginning of the video, hit the home key on your keyboard.

Figure 3: Load media window - note the icons top right for more options



4 – Choose Output Format

You can skip this step if you want the format of your output to be the same as your input.  However, to 
create output media that is widely viewable on many platforms, to include phones and television, you 
should set your format accordingly.

1) On the main timeline, use the Settings pulldown (about the 7th pulldown from the left side top) and
    click on “Format” which is the first option in that list.
2) A “Set Format” menu will appear that shows what the current format is for your loaded media in an
    Audio and a Video tab.  In the United States, the Video Frame rate is usually expected to be 29.970
    and usually the Color model is only changed if you have a personal preference.
3) The “Canvas size” is probably the only thing you will want to change here in order to get to the
    most commonly viewable settings.  On the right hand side of the Width parameter is a down arrow. 
    Left click the down arrow to see your options.
4) Highlight 1280x720 HD for a good common option.
5) Click OK to have this option take effect.  When you do, the Compositor window may change to fit
    this option and may look wrong sized.

 

6) If the video now looks too small or too large in the Compositor, you will want to “autoscale” it to
    look correct when the new media is created.  To do this, mouse over to the Resources window in the
    lower right hand corner and under the word Visibility, hightlight “Video Effects” to see some
    plugins.
7) Mouse over the “Auto Scale” icon, left click to highlight the words underneath the icon, and mouse
    drag the icon to the timeline video track.  When you see a white colored outline show on that track,
    drop the Auto Scale icon there and you will see that the video may now automatically scale to a

Figure 4: Format menu to change settings

Figure 5: Note brown bar with magnifier



    new value.  Click on the magnifying glass icon on the brown colored line beneath the main timeline
    video which opens a new window.  In that window, again use the down arrow to choose 1280x720
    HD, then dismiss this window.
8) If not needed, to remove the Auto Scale plugin, right mouse on the brown line and choose Detach.

5 - View and Listen

1) On the second line, below the pulldowns, are transport buttons to move back and forth on the
    timeline and play forward or reverse, fast or slow, or a single frame.  When you mouse over one of
    these buttons, a yellow-colored tooltip appears to tell you its function along with a key shortcut
    inside of parenthesis.  When you left click the mouse on the transport button it starts the play and 
    click again to stop it.  As you use these buttons, watch the Compositor to watch your video.

2) On the timeline, you only see thumbnails and not every single picture/waveform.  You may want to
    use your keyboard’s down arrow to expand the thumbnails and the up arrow to unexpand them – on
    United States keyboard, the arrow keys are generally together on the lower right hand side of the
    keyboard, a little to the right of the space bar.  This is a more cpu intensive operation and for very
    large video can be time-consuming.

6 - Edit/Compose

There may be sections of your media that you want to delete, or audio that is hard to hear and needs to 
be enhanced, or there is a need for a descriptive title that you want to add.  Here are a few basics.  But 
first be sure that you are in “cut and paste” mode (this is the default) by checking to verify that you see 
a gold color around the “I” i-beam mode icon as in the figure above.  If the arrow to the left is gold 
instead, you are in “drag and drop” mode so switch to “cut and paste” by clicking on the “I” instead.

1) You should look at the “Edit” pulldown - 2nd from the upper left on the main timeline to see the
    most common options to use.  The first option in the list is “Undo” followed by a terse comment of  
    the last operation that you performed that can be undone.
2) To delete a section of video/audio is described next.  Various ways to do that are available but the
    easiest is to move your mouse and left click at the beginning of the section you want to delete on the
    timeline and while holding down the left mouse button, drag to the end of the section to be deleted. 
    When you do this, a white colored highlighted section becomes visible.  Use the edit pulldown and
    choose the split/cut option to cut out the highlighted area (note the shortcut of x).  Remember if you
    cut the wrong thing out you can always use the Edit pulldown to Undo that.
3) To add a transition where there is deleted section which may make your video look disjointed, do
    the following.   Go back to the Resources window in the bottom right hand corner.  Change to
    “Video Transitions” by highlighting that underneath the word “Visibility”.  Highlight a transition like

Figure 6: Menu pulldowns at the top with Transport buttons below.  Note the yellow tooltips too.



    BandSlide with the left button mouse click, hold down and drag to the video track and when you see
    a white-colored box around the area that you deleted above, drop the icon.  Right mouse click the
    icon on the track to vary some parameters like length.
4) To insert another clip from a different video, first you have to load the other video on another track.
    Go to File pulldown again and choose the Load files option.  Type in a directory at the top again and
    erase any specific file that you may have chosen previously in the bottom 2 textboxes.  It is very
    important to now change the Insertion strategy to “Append in new tracks” or you will write over
    your current work.  But if you make this mistake, you can use the Edit pulldown and Undo that!

    a) Once the new video is on the track below your current work, you want to work with only this new 
        track, so disarm your other tracks by looking to the left of each track’s timeline and click the 2nd 
        button beneath the track name, for example Video 1 or Audio 1.  The track name textbox will turn
        red to remind you that the track has been disarmed.  The boxed area is called the patchbay.

   b) Move to the area you want to make a clip of on your newly loaded track, hold down the left mouse
       button and drag the area to be made into a clip which will turn the color white.  Remember, you
       disarmed the other tracks so only this track is relevant at this time.  On the second line of the main
       window to the right of the transport buttons, are action buttons and as you mouse over them a
       yellow colored tooltip explains its purpose.  Find the one that says “To clip” which is on the right
       hand side of the right bracket symbol. 
   c) Click on “To clip” and a small window comes up which you can comment in but it is not necessary
        so just click on the green checkmark and now you will have a clip.
   d) Disarm that new track and re-arm your original tracks so you can go back to working on them.
   e) Move your cursor to the spot in your original video where you want to insert the clip.   Make a

Figure 7: Audio 1 is disarmed.                      BandSlide transition above.     A highlighted section.



       “Split” with the “Split | Cut” option.
   f) Go to the Resources window and under the word Visibility, highlight Clips so you can see your
       recently created clip in the box to the right.  Highlight that clip and drag it to where you did the
       blade cut and drop it in.

5) To add a Title or any wording you will use the Title plugin.  In the Resources window, under the
    word “Visibility”, highlight Video Effects.  In the box to the right, many plugin icons appear.   Scroll
    to the right using the scroll bar at the bottom of the Resources window to locate Title.  Highlight the
    Title icon and drag/drop to your video track.  By now your video track may be in sections as you
    deleted, added blade cuts, and inserts so where you drop the Title icon will be surrounded with a
    white colored box.  It will take effect in that entire area so you may want to highlight a section as
    usual with left mouse click on the timeline and drag to the end of the desired area.

    a) Right click on the brown colored bar that appeared below your video track to get to options and
        then left click on Show to get the Title window to appear.
     b) Now for the fun part.  First type in some words in the bottom large text box just to see what it
         does.  There are so many variable parameters here and they are a lot of fun to play around with.
     c) You can dismiss the Title window when finished BUT be sure to leave the brown colored Title bar
         on the track.  And if you enabled the “drag” feature, you should disable it so you do not forget.
     d) Right mouse click on the bottom Text box to see many more interesting parameters.

Figure 8: Compositor + Title menu for setting parameters + the Color Picker



7 - Back up your work 
At this time, or even earlier if you think you might make a mistake or if you are concerned about 
computer crashes, you should save your work.  Use the File pulldown, and you can use “Save as” to 
designate a directory and filename.  Then click the green checkmark.  You are saving the EDL which is 
the set of changes that you have made – this file is separate from your original media.

8 - Create your new media
1) Once again in the main Program window, click on the File pulldown and highlight/click the Render
    option which is about the 9h option down from the top of the list.  A Cinelerra Render menu will
    appear.
2) First keyin the first textbox the file to render to under “Select a file to render to”
3) For the File Format, click on the down arrow and select FFMPEG (because this is the most
    commonly used format; later you may want to experiment with others).  To the right of that box,
    click on the down arrow and highlight mp4 – again because this is common.  When you click on 
    mp4, notice that if there is an extension to your filename in the “file to render to” above, it may
    change it to mp4 and if there is none, it will add “.mp4” because that is what is expected.
4) Make sure there is a red colored checkmark next to the words Audio and Video right below if you
    have/want both audio and video.  To the left of that checkmark box, is a symbol that looks like a
    wrench.  Click on this for Audio just to see the default Preset options which are just fine so dismiss
    the menu.  Then click on the wrench for Video and check Pixels by using the down arrow to the
    right to be yuv420p – this is most commonly usable option.  And click on the green checkmark.
5) Check the Insertion Strategy in the Render Menu window.  You might want to change that to
    a different strategy than the default of “Append in new tracks”.  If not, then when the Render is done,
    your new video will automatically be loaded in another set of tracks below your work tracks.  Click
    on the green checkmark in the lower left corner to start the render.
6) As the render is running, you will see the video play by in the Compositor.  Rendering is usually
    slow, especially with plugins added.

9 - Play your new media

The file you created in the Render step should now be playable.  You can test this in cinelerra most 
easily by going to the Resource window in the lower right corner, clicking on the Media folder, and 
dragging and dropping the last video to the Viewer window.  There is a separate set of transport buttons 
on the bottom on that screen to use for playing.
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