
Notes on using the Cinelerra Good Guy Video Editor with still images: Richard Nolde, 5/1/2020

This tutorial was created on Fedora 30 running the XFCE desktop and using the Cinelerra Good Guy 
version 5.1 RPM package dated November 15th, 2019, from the RPM Fusion repository. I used the S.U.V. 
theme since that seems to be the theme most commonly seen in online video tutorials. 

I created this tutorial as a response to difficulties I encountered when trying to make a video which 
includes TIFF images converted from raw Nikon DSLR images with Raw Therapee. My problems were due to 
an assumption that I made about how Cinelerra would handle images that included an alpha transparency layer. 
If common image viewers could display images with transparency correctly, I assumed that Cinelerra would do 
the same and the transparent parts of the image would automatically reveal any tracks below them in the stack. 
However, images created with Gimp that have transparency will show up as though there were no transparency. 
This is true whether the image file format is PNG or TIFF. You must replace the alpha channel with a uniform 
background color, e.g., bright green, so that it can be removed with the Chroma key effect.  

A basic knowledge of Gimp is a prerequisite for this tutorial. The instructions for using Gimp are based 
on Gimp 2.10.14 with the Gimp Light theme. Each tool in Gimp has a set of options that can be modified to 
alter how the tool acts on the image or layer. These are not automatically displayed, but you can force them to 
appear by selecting the Windows item at the top of the frame and choosing Tool Options from the Dockable 
Dialogs item. The contents of the Tool Options window will change for each tool that you select.

These techniques are used to isolate one or more portions of an image from the background so that the 
image can be used with the Chroma key effect in Cinelerra. They can also be used to add objects to images or 
move them to portions of the image that won’t be blocked by a title or overlay. For those uses, however, you 
will just copy the extracted portions of the image into a new layer or a copy of the original image. When used 
with the Chroma key effect in Cinelerra, the resulting images can be used to suggest motion with the camera 
positioning options found in the Cinelerra Compositor. The images are still two dimensional so the result is a 
sort of animation on the cheap rather than what you might get with a full three dimensional model in Blender. 

The following sequence of screen captures and directions describe how to use the Gimp to prepare an 
image for use with the Chroma key-HSV effect in Cinelerra. First, change the default black foreground color to 
a solid color not found in the desired foreground objects. In this case, I have chosen a bright lime green but it 
can be any color that is not found in the objects you desire to isolate.

Gimp dialog to Change Foreground Color to a new color



Sample image (actually a crop of a much larger image)

Isolate the foreground objects with the rectangle or ellipse selection tools to enclose the object.

Initial rectangle selection.

Next, invert the selection so that only the area outside of the rectangle is selected, Select->Invert, and then Edit-
>Fill with Foreground Color, having set it to bright green previously as shown below.



 

It may be helpful to do all of this in a second layer into which a copy of the original image has been 
created using the sequence: Select->All, Edit->Copy, Edit->Paste as New Layer, and then turn off visibility for 
the original background layer and protect it with the lock layer option in the Layers dialog box. In your working 
layer, select as many segments of the background color as you can using the rectangle, ellipse, or freehand 
selection tools, either one at a time or by combining selections. Each time you make a selection convert it to the 
foreground color with Edit->Fill with Foreground Color. The purpose of this is to limit the amount of time you 
spend isolating the foreground objects.

Using the Free Select tool to create an irregular selection.

The selection includes all the areas outside of the birds, which you can then use Edit->Fill with 
Foreground Color to remove the original background. Turn off the Feather Edges option in the Tool Options 
dialog for the Free Select Tool before drawing the lines. At this point, you can try any of several tools in 
sequence for various parts of the remaining background. My first choice is the Fuzzy Select Tool to find 
contiguous regions with the same or similar colors. You will have to tweak the tool’s options to find the settings 
that work best to isolate the foreground subjects without eroding their edges. This will be largely dependent on 
the colors in the background and the desired objects. I selected the blue sky background to get the result below.



Outlines created by the Fuzzy Select Tool

Don’t worry about the external borders that were left when I forgot to turn off Feather Edges in the 
previous step. They can be removed with the eraser tool (flip foreground and background first), or captured with 
the Free select Tool and filled with the foreground color in a few steps as shown below.

Area selected by Fuzzy Select color tool and then filled with new color

At this point, you can zoom in and use the Free Select tool to trim up the edges of the foreground 
objects. If there are multiple foreground objects, you do not want to use the select and invert sequence described 
above or you will erase the remaining objects. Instead, select a region of the area near the object, convert that to 
the desired color, and repeat until you have all the unwanted pixels converted to the desired color.  Don’t try to 



outline the whole object in a single sequence. You can use the history dialog to back out of anything that didn’t 
work as planned and start again from the last good step. If you saved the original image in an extra layer, you 
can restore selections gone awry by copying over them from the original image. Also, it never hurts to save 
your work with incremental file names as you go along.

Two regions above and below selected with the Free Select Tool

When zooming in to get at fine details of the image, Gimp allows you to manually specify the zoom 
level rather than using only the values on the pop-up at the bottom border of the frame, e.g., 300% rather than 
200% or 400%. Always Select->None before starting a new outline and fill sequence.



Final selection used to isolate the two birds, 200% magnification

Result at 100% magnification in Gimp

I find that some combination of the Free Select Tool, Fuzzy Select Tool, and the Intelligent Scissors 
tools will generally work well enough, but which one you use will depend on the sharpness of the edges and the 
homogeneity of the background. If your background has lots of details, you may have to use the Free Select 



Tool exclusively. When the foreground object is going to be displayed in front of a background that is similar to 
the original background, the accuracy of the edge is much less important than when the object is going to be 
displayed on a contrasting background. The Chroma key-HSV effect has options to deal with the sharpness of 
the edges as well. If the isolated objects are going to be used to simulate motion in front of a fixed background, 
the details are almost invisible when the object is panned across the background unless you have zoomed in to 
a high magnification.

When you have isolated the foreground objects you should save a copy of your work in Gimp’s native 
XCF format before you flatten the image if you added any additional layers. This will allow you to resume from 
that point if the exported image doesn’t work well in Cinelerra. However, to use the image in Cinelerra, you 
must unlock any background layers, merge your working layer (with your desired background color 
surrounding the foreground objects) down until it is the only layer in the image, and remove any transparency. 
You should then export the image in TIFF format without Preserve Layers selected. It does not need to be 
reduced to the size of the video format that you are going to use in your project. In fact, if you are going to 
simulate animation by moving the objects around in front of a background, leave the image larger than the 
video format’s dimensions.

The reason that it is important to select a new background color that is absent from the foreground 
objects is that the Chroma key effect will not know anything about the objects themselves. It uses a simple 
color-matching algorithm to turn all pixels of a certain color into transparent pixels for that layer of the video, 
whether or not they are inside or outside of the foreground object that you are trying to isolate. The Chroma key 
effect has allowances for slight variations in the actual hue, saturation, and luminance, but whatever range of 
values you select will apply to the entire image or video clip to which the Chromakey effect has been applied. I 
experimented with creating masks and using different overlay modes and the results were much less satisfactory 
than using the Chroma key effect.

I originally tried to use Gimp’s ability to add alpha channel transparency to an image so that only the 
foreground object appeared on screen over Gimp’s default hatch pattern that indicates transparency.

Moon extracted by converting surrounding area to an alpha channel mask.

As noted in the opening paragraphs, I thought that I could simply add this image to a Cinelerra track and the 
surrounding transparent portion would allow the background image or video to show through. Cinelerra ignored 
the alpha channel mask in the imported image and the background sky appeared where I expected transparency. 
The sequence described above appears to be the only way to isolate foreground objects from their background. 

Images for use with the Chroma key effect must be assigned to tracks above the background image or 
video. It is possible to stack multiple images of different foreground objects, each with the Chroma key effect 



set to match the same or a different background color for each image. The order of the tracks will determine 
which objects obscure other objects.  Each image can be moved and scaled independently using the projector 
and camera controls in the Cinelerra Compositor window. Unless you are going to fade in and fade out each 
image containing a foreground object, or you are aiming for an unnatural effect like sprites popping up and 
disappearing, it is better if you use the camera positioning options in the Compositor window to move the 
objects out of the frame at the beginning and end of each clip.

You cannot, at least as far as I can tell, move individual objects within a static image independently as a 
true animation package would allow you to do. You can create the same effect by isolating each object or group 
of objects and saving them to separate image files which you then load on individual tracks in Cinelerra and 
manipulate them on a per-image basis. I used this procedure to add a moon to a landscape in front of which 
several flocks of birds appear to glide from one side of the frame to the other. 

It is important to note the natural light when making these sort of compilations. Your video will not be 
convincing if the light on one natural subject appears to come from one direction and the light on another 
subject appears to come from a different direction. Also, adding a moon to a landscape may suggest the position 
of the sun relative to the subject. If there are shadows in the landscape they should be consistent with the 
position of the sun. This is easier if all the images used in the built-up frames are taken at or near the same time 
and from roughly the same position. If different lenses or focal lengths are used, it may be necessary to correct 
for various distortions before processing the images as described above. While Cinelerra can import raw format 
images created by some DSLRs, you are much better off processing the raw images in Raw Therapee or another 
image-processing package that allows for exposure compensation, chromatic aberration correction, vignetting 
correction, and color temperature compensation before exporting the corrected data in TIFF format. Raw 
Therapee allows you to save a set of corrections as a custom profile, which you can then apply to additional 
images from a given set before making final adjustments.

Screen capture of one rendered video frame

For the frame shown above, I first added the moon to the static background image. Next, I used a second 
image with four cranes and moved a crane from the right side of the image into the middle of the frame with the 
other cranes. Finally, I modified the background of the crane image for use with the Chroma key effect in 
Cinelerra. The four cranes float into the frame from the upper left and leave at the lower right corner before 
another flock passes across the screen. I allow 5 seconds for each flock to pass in front of the camera but they 
could be overlapped or follow each other before the preceding group has left the viewport.



In Cinelerra, select a video format that supports transparency, e.g., RGBA or YUVA for your video on 
the Settings->Format tab.

Full HD video with alpha channel

The background image must be positioned on the lowest track and will have the Overlay Mode set to 
Normal. This allows the tracks above with Chroma key effect enabled to float above the background. It isn’t 
necessary to place each static image on a unique track unless you are applying a mask that affects the entire 
track. I have placed several images on each track to make it easier to see the sequence. By alternating tracks for 
successive images, you can adjust them to overlap as you fade in and out or pan the foreground objects around 
in the viewport. If the Overlay Mode of the Chroma keyed images is set to Normal, foreground objects will 
appear to pass in front of (i.e. obscure) objects on layers below them as well as the background image. Other 
effects can also be applied to individual images or tracks.

Track layout for individual static images over composite background image



Background image with previously added moon scaled to fit video frame

You can use different parameters in the Compositor->Camera controls box shown on the left for each 
image. The values in the dialog do not automatically update as the video plays or when you click on different 
positions on the time lines in the main window or the Compositor window.  Follow these steps to guarantee that 
the values you are seeing correspond to the position of the image in the video frame at any given time.

First, arm the track that contains the Chroma keyed image that you wish to manipulate and disarm all 
the remaining tracks by holding down the shift key and clicking the red button below the title bar on the left 
side of the track. Enlarge the vertical region for the track and scroll the tracks window to focus on the track you 
are working on. Set the cursor to the exact frame that starts the image you want to manipulate by using the up or 
down arrow keys to display single frames. The image below shows the screen for a single Chroma keyed image 
spanning a 5 second segment at the beginning of the video. You can confirm the cursor position by checking the 
digital readout at the bottom of the panel to the left of the audio fader slider.

A single armed track/image enlarged in the track panel showing panning curves



When you align the cursor at the first frame of the image, the Compositor window should display the 
coordinates and zoom level in the Camera Position dialog for that frame. If the values do not update, disarm and 
then rearm only that track. The main Compositor window will display a green frame representing the video 
frame, a yellow frame representing the full image size as rendered at the current zoom level shown in the dialog 
box. If your static image is much larger than the video frame, the edges of the yellow box may not be visible 
even when you set the Compositor zoom level to 25%. You can make the Compositor window larger or just use 
the center horizontally and vertically buttons in the dialog box to get the image onto the Compositor screen. It 
may require a brute force approach of typing in values in the X, Y, and Z tabs to get a good alignment. You can 
also drag on the image to move it but this will be much less precise. Depending on the magnification used in the 
Compositor, there may be sliders to adjust the viewport on the bottom and right side of the Compositor window.

Positions of first frame of a Chroma key image with foreground subjects out of view

You cannot display the last frame of the video segment for an individual image by positioning the time 
line cursor at the very end of the clip. Cinelerra always displays the frame following the cursor position which 
is beyond the end of the clip. To see where the foreground objects are at the end of the clip, you have to back up 
one frame from the end by manually positioning the cursor with the mouse or using the 4 key on the numeric 
keypad when you have reached the end of the clip. You can also check the readout in the position box at the 
bottom of the time line window. If you know that the image should be moving on the Compositor window and 
the Camera dialog doesn’t update, make sure that you have armed the right track and only that track.

Positions of last frame of the same Chroma key image with foreground subjects out of view



In order to see where the Chroma keyed objects will be at the end of the clip, you have to set the 
keyframe markers one frame before the end of the clip. In most cases that doesn’t matter but if you are 
following that clip with another one on the same track that starts at a very different set of coordinates, you can 
get strange artifacts during that one frame since you cannot have two values for a single keyframe at one 
position in the time line. It’s better to position Chroma keyed images on different tracks so that the generated X, 
Y, and Z coordinates don’t become impossible to manage.

Actual appearance of video frame half way through clip, Note: dialog values have not updated

 One of the most frustrating aspects of using the camera position widget is that there is no way to make 
the values in the dialog update as the video plays, or even when you click on a specific location on the time 
line. If you have the Generate Keyframes While Tweaking option set, you will get a new keyframe anytime you 
drag the image around in the Compositor. However, if that option is turned off, you can move the frame around, 
note the values in the Compositor Projector window, and then move to the position on the time line where you 
want to set those values. Restore the Generate Keyframes While Tweaking option, move the frame slightly to 
create a keyframe, and type in the values you noted to save the exact position and zoom. 

It is helpful to record these values in a spreadsheet annotating each image and track so that you can 
reinstate them when things inevitably go south due to clicking somewhere you did not intend to. If you forget to 
disarm all but the current track you can easily wreck a days worth of work in a few minutes. Record such things 
as the exact time and frame when the image appears in and leaves the video track, the pan and zoom values for 
the camera position, and the projector values if your are using picture in a picture or split screen effects.

 It can also be helpful to turn off the output from all tracks not involved in the current segment of your 
video so you are not confused by them. I recommend not using the Mute button (pop-up says “Don’t send to 
Output”) as you can create all sorts of holes in your video without realizing it. The green triangle to the left of 
the arm track button toggles visibility in the Compositor window safely. If your Chroma keyed images overlap 
each other, you will need to use the green triangle to toggle which ones are visible and arm only the one for 
which you want to modify the coordinates. When tweaking values by dragging individual keyframe curves on 
the track below the time line, turn off unused curves in the Cinelerra: Overlay dialog temporarily. This is 
particularly important if you are trying to set a fade keyframe that is independent of the other parameters.

To add the Chroma key effect, select the Use Color Picker option in the Compositor for the Chroma key 
image before the Chroma key effect is enabled and set the visibility of the background image to off temporarily. 
If you haven’t prepared your static images in a graphics editor such as Gimp, you will have to tweak the settings 
for each image with the control dialog box for the Chroma key effect. On the other hand, if all of your Chroma 
keyed images use the same background color to render the transparency, then you should not have to tweak the 
settings after you get them set correctly for the first Chroma keyed image. 



Control dialog window for Chroma key-HSV effect

Control dialogs for various widgets can pop up behind the Compositor. This is particularly difficult to 
detect if you have set the Compositor window to Always on Top mode with your window manager to give it a 
larger view. If you click on a button that should produce a result and nothing happens, first check that the dialog 
isn’t behind another window. Keep things like the preview and resource windows rolled up unless you are 
actively using them.  Your window manager should have a small icon for each active window somewhere in its 
hierarchy of on-screen widgets. Mousing over each one should identify the missing control dialog window.

Window manager identifier icons at bottom of active window


